

The CookieProcessor element represents the component that
parses received cookie headers into javax.servlet.http.Cookie
objects accessible through HttpServletRequest.getCookies() and
converts javax.servlet.http.Cookie objects added to the response
through HttpServletResponse.addCookie() to the HTTP headers
returned to the client.
A CookieProcessor element MAY be nested inside a Context component. If it is not included, a default implementation will be created automatically.
Note: CookieProcessor is a new configuration element, introduced in Tomcat 8.0.15.
conf/context.xml file. The legacy cookie parsing algorithm
supported only limited global configuration via several
system properties. Those
system properties are still supported, but are going to be deprecated in
favor of this new configuration element.
className attribute
on CookieProcessor element.All implementations of CookieProcessor support the following attributes:
| Attribute | Description |
|---|---|
className |
Java class name of the implementation to use. This class must
implement the |
The standard implementation of CookieProcessor is
org.apache.tomcat.util.http.LegacyCookieProcessor. Note
that it is anticipated that this will change to
org.apache.tomcat.util.http.Rfc6265CookieProcessor in a future
Tomcat 8 release.
This is the legacy cookie parser based on RFC6265, RFC2109 and RFC2616. It implements a strict interpretation of the cookie specifications. Due to various interoperability issues with browsers not all strict behaviours are enabled by default and additional options are available to further relax the behaviour of this cookie processor if required.
| Attribute | Description |
|---|---|
allowEqualsInValue |
If this is If not set the specification compliant default value of
|
allowHttpSepsInV0 |
If this is If not specified, the default specification compliant value of
|
allowNameOnly |
If this is If not set the specification compliant default value of
|
alwaysAddExpires |
If this is If |
forwardSlashIsSeparator |
If this is |
preserveCookieHeader |
This attribute is no longer used. From Tomcat 8.0.31, Tomcat will
always preserve the cookie header returned by
|
This cookie processor is based on RFC6265 with the following changes to support better interoperability:
The RFC 6265 cookie processor is generally more lenient than the legacy cookie parser. In particular:
=' and '/' characters are always
permitted in a cookie value.No additional attributes are supported by the RFC 6265 Cookie Processor.
No element may be nested inside a CookieProcessor.
No special features are associated with a CookieProcessor element.